sql server 常见错误代码15000 - 15999含义解析

时间:2015-04-15 00:54:56   收藏:0   阅读:1289

错误 15000 - 15999

SQL Server 2008 R2

其他版本

技术分享

 

错误

严重性

是否记录事件

说明(消息正文)

15001

16

否

对象 ‘%ls‘ 不存在或不是此操作的有效对象。

15002

16

否

无法在事务中执行过程 ‘%s‘。

15003

16

否

只有 %s 角色的成员才能执行此存储过程。

15004

16

否

名称不能是 NULL。

15005

10

否

已更新了所有表的统计信息。

15006

16

否

‘%s‘ 是无效名称,因为其中包含无效字符。

15007

16

否

‘%s‘ 是无效登录名或您没有相应的权限。

15008

16

否

用户 ‘%s‘ 在当前数据库中不存在。

15009

16

否

对象 ‘%s‘ 在数据库 ‘%s‘ 中不存在或对于此操作无效。

15010

16

否

数据库 ‘%s‘ 不存在。请提供有效的数据库名称。若要查看可用数据库,请使用 sys.databases。

15011

16

否

数据库选项 ‘%s‘ 不存在。请指定有效的数据库选项。

15012

16

否

设备 ‘%s‘ 不存在。请使用 sys.backup_devices 来显示可用的设备。

15013

10

否

表 ‘%s‘: 找不到无统计信息的列。

15014

16

否

角色 ‘%s‘ 在当前数据库中不存在。

15015

16

否

服务器 ‘%s‘ 不存在。请使用 sp_helpserver 来显示可用的服务器。

15016

16

否

默认值 ‘%s‘ 不存在。

15017

16

否

规则 ‘%s‘ 不存在。

15018

10

否

表 ‘%s‘: 正为以下列创建统计信息:

15019

16

否

扩展存储过程 ‘%s‘ 不存在。

15020

10

否

已为上述表中所列出的 %d 个列创建了统计信息。

15021

16

否

为参数 %s 提供的值无效。请指定有效的参数值。

15022

16

否

指定的用户名已有别名。

15023

16

否

用户、组或角色 ‘%s‘ 在当前数据库中已存在。

15025

16

否

服务器主体 ‘%s‘ 已存在。

15026

16

否

逻辑设备 ‘%s‘ 已存在。

15028

16

否

服务器 ‘%s‘ 已存在。

15032

16

否

数据库 ‘%s‘ 已存在。请指定唯一的数据库名称。

15033

16

否

‘%s‘ 不是有效的正式语言名称。

15034

16

否

应用程序角色密码不能是 NULL。

15036

16

否

数据类型 ‘%s‘ 不存在或您没有权限。

15040

16

否

对于用户定义的错误信息,其 ID 必须大于 50000。

15041

16

否

对于用户定义的错误信息,其严重级别必须介于 1 和 25 之间。

15042

10

否

对于版本不是 us_english 的消息,忽略 @with_log 参数。

15043

16

否

必须指定 ‘REPLACE‘ 以覆盖现有的消息。

15044

16

否

类型 "%s" 是未知的备份设备类型。请使用类型 "磁盘" 或 "磁带"。

15045

16

否

逻辑名称不可以是 NULL。

15046

16

否

物理名称不可以是 NULL。

15048

10

否

数据库兼容级别的有效值为 %d、%d 或 %d。

15049

11

否

无法从 ‘%s‘ 取消绑定。请使用 ALTER TABLE DROP CONSTRAINT。

15050

11

否

无法绑定默认值 ‘%s‘。必须使用 CREATE DEFAULT 语句创建默认值。

15051

11

否

该表已为了复制而被发布,所以无法重命名。

15053

16

否

存在不属于数据库所有者的对象。

15054

10

否

当前的兼容级别为 %d。

15056

10

否

数据库 "%s" 上的可疑标志已经重置。

15057

16

否

%s 名称的列表中包含空格,这是不允许的。

15058

16

否

%s 的列表中的名称太少。

15059

16

否

%s 的列表中的名称太多。

15060

16

否

%s 名称的列表中,有些名称包含 ‘%s‘ 非字母字符。

15061

16

否

添加设备的请求被拒。名为 "%s" 的物理设备已存在。对于任何一个物理设备名称,只有一个备份设备可以引用。

15062

16

否

guest 用户不能映射到登录名。

15063

16

否

该登录已用另一个用户名开立帐户。

15065

16

否

所有的用户 ID 均已指派。

15066

16

否

来自远程服务器 ‘%s‘ 的远程登录的默认名称映射已存在。

15068

16

否

远程服务器 ‘%s‘ 已存在远程用户 ‘%s‘。

15069

16

否

一个或多个用户正在使用该数据库。无法完成请求的操作。

15070

10

否

已成功地标记对象 ‘%s‘,以便对它重新进行编译。

15071

16

否

用法: sp_addmessage <消息号>,<严重性>,<消息正文> [,<语言> [,FALSE | TRUE [,REPLACE]]]

15072

16

否

用法: sp_addremotelogin remoteserver [,loginname [,remotename]]

15074

10

否

警告: 必须先恢复此数据库,然后才能访问它。

15076

16

否

默认值、表和用户数据类型必须位于当前数据库中。

15077

16

否

规则、表和用户数据类型必须位于当前数据库中。

15078

16

否

表或视图必须位于当前数据库中。

15079

10

否

已处理的查询数目: %d。

15080

16

否

不能使用参数 %s 进行 Windows 登录。

15081

16

否

不能更改公共角色的成员身份。

15083

16

否

物理数据类型 ‘%s‘ 不接受排序规则

15084

16

否

列或用户数据类型必须位于当前数据库中。

15085

16

否

用法: sp_addtype name, ‘data type‘ [,‘NULL‘ | ‘NOT NULL‘]

15096

16

否

找不到对象 ‘%ls‘,或者您没有所需的权限或对象无效,以致无法添加扩展属性。

15097

16

否

与扩展属性相关的大小不能超过 7500 个字节。

15098

16

否

由于新名称的 SID 与主体的旧 SID 不匹配,因此无法更改名称。

15099

16

否

当 CHECK_EXPIRATION 设为 OFF (关)时,不能使用 MUST_CHANGE 选项。

15100

16

否

用法: sp_bindefault defaultname, objectname [, ‘futureonly‘]

15101

16

否

无法将默认值绑定到计算列、稀疏列或以下数据类型的列: timestamp、varchar(max)、nvarchar(max)、varbinary(max)、xml 或 CLR 类型。

15102

16

否

无法将默认值绑定到标识列。

15103

16

否

无法将默认值绑定到用默认值创建的列或被更改为有默认值的列。

15104

16

否

您并不拥有名为 ‘%s‘、包含列 ‘%s‘ 的表。

15106

16

否

用法: sp_bindrule rulename, objectname [, ‘futureonly‘]

15107

16

否

无法将规则绑定到计算列、稀疏列或以下数据类型的列: text、ntext、image、timestamp、varchar(max)、nvarchar(max)、varbinary(max)、xml 或用户定义数据类型。

15108

16

否

sp_addtype 不能用来为 varchar(max)、nvarchar(max) 或 varbinary(max) 数据类型定义用户定义的数据类型。请使用 CREATE TYPE。

15109

16

否

无法更改 master 数据库、model 数据库、tempdb 数据库或分发数据库的所有者。

15110

16

否

推荐的新数据库所有者已经是此数据库的用户或在此数据库中已有一个别名。

15112

11

否

表选项 ‘text in row‘ 的第三个参数无效。该参数应为 ‘on‘、‘off‘、‘0‘ 或介于 24 和 7000 之间的数字。

15113

16

否

失败的登录尝试过多。为防止进行密码推测,已暂时锁定此帐户。系统管理员可以使用 ALTER LOGIN 的 UNLOCK 子句将此登录名解锁。

15114

16

否

密码有效性验证失败。该用户的密码太新,不能更改。

15115

16

否

密码有效性验证失败。此时不能使用该密码。

15116

16

否

密码有效性验证失败。该密码太短,不符合 Windows 策略要求。

15117

16

否

密码有效性验证失败。密码太长,不符合 Windows 策略要求。

15118

16

否

密码有效性验证失败。该密码不够复杂,不符合 Windows 策略要求。

15119

16

否

密码有效性验证失败。该密码不符合密码筛选器 DLL 的要求。

15120

16

否

密码验证期间出错。

15121

16

否

在执行 %ls 的过程中出错。调用 ‘%ls‘ 失败,错误代码: ‘%d‘。

15122

16

否

在 CHECK_POLICY 设为 OFF (关)时,不能使用 CHECK_EXPIRATION 选项。

15123

16

否

配置选项 ‘%s‘ 不存在,也可能是高级选项。

15124

16

否

配置选项 ‘%s‘ 不是唯一的。

15125

16

否

触发器 ‘%s‘ 不是 ‘%s‘ 的触发器。

15127

16

否

无法将默认语言设置为未在 syslanguages 中定义的语言 ID。

15128

16

否

当 MUST_CHANGE 为 ON (开)时,不能将 CHECK_POLICY 和 CHECK_EXPIRATION 选项设为 OFF (关)。

15129

16

否

‘%d‘ 不是配置选项 ‘%s‘ 的有效值。

15130

16

否

已存在 ‘%s‘ 的触发器 ‘%s‘。

15131

16

否

用法: sp_dbremove <数据库名称> [,dropdev]

15133

16

否

INSTEAD OF 触发器 ‘%s‘ 不能与顺序相关联。

15134

16

否

指定的用户没有别名。

15135

16

否

对象无效。‘%s‘ 不允许有扩展属性,或对象不存在。

15136

16

否

数据库主体已设置为一个或多个过程、函数或事件通知的执行上下文,无法删除。

15137

16

否

在执行 sp_xp_cmdshell_proxy_account 的过程中出错。可能原因: 提供的帐户无效或无法创建 ‘%.*ls‘ 凭据。错误代码: ‘%d‘。

15138

16

否

数据库主体在该数据库中拥有 %S_MSG,无法删除。

15141

16

否

服务器主体拥有一个或多个 %S_MSG,无法删除。

15143

16

否

‘%s‘ 不是 @updateusage 参数的有效选项。请输入 ‘true‘ 或 ‘false‘。

15144

16

否

该角色有多个成员。角色必须为空后才能删除。

15145

16

否

隐式创建 %S_MSG 失败。原因: %S_MSG 可能已删除或其名称可能已在使用。

15146

16

否

必须提供加密密码才能加密此 %S_MSG 的私钥。

15147

16

否

由于此 %S_MSG 的私钥已用主密钥加密,因此不应提供解密密码。

15148

16

否

数据类型或表列 ‘%s‘ 不存在,或您没有所需的权限。

15149

16

否

主体不存在或没有足够的特权。

15150

16

否

无法对 %S_MSG ‘%.*ls‘ 执行 %S_MSG。

15151

16

否

无法对 %S_MSG ‘%.*ls‘ 执行 %S_MSG,因为它不存在,或者您没有所需的权限。

15152

16

否

无法更新用户实例。原因: %ls。错误代码: 0x%x。

15153

16

否

xp_cmdshell 代理帐户信息无法检索或无效。请验证 ‘%.*ls‘ 凭据存在并且包含有效的信息。

15154

16

否

数据库主体拥有 %S_MSG,无法删除。

15155

16

否

服务器主体拥有 %S_MSG,无法删除。

15156

16

否

您指定的密码过长。密码的长度不能超过 %d 个字符。

15157

16

否

由于以下原因之一,setuser 失败: 数据库主体 ‘%.*ls‘ 不存在,与数据库主体对应的服务器主体没有服务器访问权限,无法模拟此类型的数据库主体或您没有权限。

15158

16

否

无法初始化安全设置。

15159

16

否

超过了最大模拟嵌套级别(限制为 %d)。

15160

16

否

无法从非主模拟上下文发放模拟令牌或为非 Windows 用户发放模拟令牌。

15161

16

否

无法设置应用程序角色 ‘%.*ls‘,因为此角色不存在或密码不正确。

15162

16

否

创建模拟令牌时出错。

15163

16

否

超时值无效。有效超时值应介于 1 和 7200 秒之间。

15164

16

否

‘%.*ls‘ 不是有效的登录名或无法向其颁发模拟令牌。

15165

16

否

找不到对象 ‘%ls‘,或者您没有所需的权限。

15166

10

否

警告: 通过 sp_addtype 创建的用户类型包含在 dbo 架构中。如果指定了 @owner 参数,则忽略该参数。

15167

16

否

无法生成 GUID。

15168

16

否

无法重命名视图 ‘%s‘ 及其列和索引,因为它是系统出于优化目的生成的视图。

15169

16

否

此版本的 SQL Server 没有服务器选项 "%ls"。

15170

16

否

此登录名是 %ld 个作业的所有者。必须删除或重新指派这些作业后,才能删除该登录名。

15171

16

否

不能使用参数 "%s" 进行证书登录或非对称密钥登录。

15172

16

否

必须在单用户模式下在 master 数据库中创建或删除后备证书。

15173

16

否

登录名 ‘%s‘ 已授予一个或多个权限。删除该登录名前请撤消相应权限。

15174

16

否

登录名 ‘%s‘ 拥有一个或多个数据库。在删除该登录名之前,请更改相应数据库的所有者。

15175

16

否

登录名 ‘%s‘ 已化名为一个或多个数据库中的某用户或已映射到一个或多个数据库中的某用户。删除该登录名之前,请删除该用户或别名。

15176

16

否

@parameter 的唯一有效值为 ‘WITH_LOG‘。

15177

16

否

用法: sp_dropmessage <消息号> [,<语言> | ‘ALL‘]

15178

16

否

无法删除或更改 ID 小于 50,000 的消息。

15179

16

否

消息号 %u 或指定的语言版本不存在。

15182

16

否

不能禁止 guest 用户访问 master 或 tempdb。

15183

16

否

数据库主体拥有该数据库中的对象,无法删除。

15184

16

否

数据库主体拥有该数据库中的数据类型,无法删除。

15185

16

否

没有从远程服务器 ‘%s‘ 映射到本地用户 ‘%s‘ 的远程用户 ‘%s‘。

15186

16

否

服务器主体已被设置为某个触发器或事件通知的执行上下文,无法删除。

15187

10

否

无法删除 %S_MSG,因为有一个或多个 %S_MSG 在使用它。

15188

16

否

无法创建未包含所有安全列的索引。

15189

16

否

表不能具有多个安全列。

15190

16

否

仍有对服务器 ‘%s‘ 的远程登录或链接登录。

15192

16

否

无法更改或删除表的安全列。

15195

16

否

此版本的 Microsoft Windows 不支持 MUST_CHANGE 选项。

15196

16

否

当前安全上下文不可还原。"Revert" 语句失败。

15197

16

否

没有对象 ‘%s‘ 的文本。

15198

16

否

提供的名称(%s)不是用户、角色或登录别名。

15199

16

否

当前安全上下文不可还原。请切换到调用 ‘%ls‘ 时所在的原始数据库,然后重试。

15200

16

否

没有定义远程服务器。

15201

16

否

没有远程服务器 ‘%s‘ 的远程登录。

15202

16

否

没有定义远程登录。

15203

16

否

没有 ‘%s‘ 的远程登录。

15204

16

否

在远程服务器 ‘%s‘ 上没有 ‘%s‘ 的远程登录。

15205

16

否

没有定义服务器。

15206

16

否

无效的远程服务器选项: ‘%s‘。

15207

16

否

不再支持远程登录映射中的可信选项。

15208

16

否

证书、非对称密钥或私钥文件不存在或格式无效。

15209

16

否

加密过程中出错。

15212

16

否

证书使用者无效。证书使用者的字符个数必须介于 1 和 %d 之间。

15213

16

否

警告: 您所创建的证书的有效期无效,其过期日期早于生效日期。

15214

16

否

警告: 您创建的证书已过期。

15215

16

否

警告: 您创建的证书尚未生效;其生效日期为将来时间。

15216

16

否

‘%s‘ 不是 @delfile 参数的有效选项。

15217

16

否

无法更新或删除属性。‘%.*ls‘ 不存在属性 ‘%.*ls‘。

15218

16

否

对象 ‘%s‘ 不是表。

15219

16

否

无法更改索引视图的所有者。

15222

16

否

远程登录选项 ‘%s‘ 不是唯一的。

15223

11

否

错误: 输入参数 ‘%s‘ 不允许为 Null。

15224

11

否

错误: @newname 参数的值包含无效字符或违反了基本限制 (%s)。

15225

11

否

在当前数据库 ‘%s‘ 中找不到名为 ‘%s‘ 的项(假定输入的 @itemtype 为 ‘%s‘)。

15226

16

否

无法从 XML 数据类型创建 CLR 类型。

15227

16

否

无法重命名数据库 ‘%s‘。

15229

16

否

为存储过程 sp_db_vardecimal_storage_format 的 "%.*ls" 参数指定的参数无效。有效的参数为 ‘ON‘ 或 ‘OFF‘。

15230

16

否

启动用户实例时出错。错误代码: %d。

15232

16

否

名为 ‘%s‘ 的证书已存在,或此证书已被添加到该数据库中。

15233

16

否

无法添加属性。‘%.*ls‘ 已存在属性 ‘%.*ls‘。

15234

16

否

此类型的对象尚未分配空间。

15236

16

否

列 ‘%s‘ 没有默认值。

15237

16

否

用户数据类型 ‘%s‘ 没有默认值。

15238

16

否

列 ‘%s‘ 没有规则。

15239

16

否

用户数据类型 ‘%s‘ 没有规则。

15240

16

否

无法写入文件 ‘%s‘。请确保您有写权限、文件路径有效以及该文件尚不存在。

15241

16

否

用法: sp_dboption [dbname [,optname [,‘true‘ | ‘false‘]]]

15242

16

否

数据库选项 ‘%s‘ 不是唯一的。

15243

16

否

无法更改 master 数据库的 ‘%s‘ 选项。

15244

16

否

只有 sysadmin 角色的成员或数据库所有者才能设置数据库选项。

15246

16

否

找不到证书 ‘%s‘ 的私钥,因此无法转储该私钥。

15247

16

否

用户没有执行此操作的权限。

15248

11

否

参数 @objname 不明确或所声明的 @objtype (%s)有误。

15249

11

否

错误: 显式 @objtype ‘%s‘ 无法识别。

15250

16

否

对象限定符的数据库名称部分必须是当前数据库的名称。

15251

16

否

指定的 ‘%s‘ 无效。它必须是 %s。

15252

16

否

必须指定主键或外键表名。

15253

11

否

分析 SQL 标识符 ‘%s‘ 时出现语法错误。

15254

16

否

该数据库中存在除数据库所有者或 guest 以外的用户。请删除这些用户后再删除该数据库。

15255

11

否

‘%s‘ 不是 @autofix 的有效值。唯一的有效值为 ‘auto‘。

15256

16

否

用法: sp_certify_removable <数据库名称> [,‘auto‘]

15257

16

否

在试图验证数据库时,不能使用该数据库。

15258

16

否

该数据库必须由 sysadmin 角色的成员拥有后才能删除。

15259

16

否

DEFAULT_SCHEMA 子句不能与 Windows 组或者映射到证书或非对称密钥的主体一起使用。

15260

16

否

安全描述符字符串 ‘%s‘ 的格式无效。

15261

16

否

用法: sp_create_removable <dbname>,<syslogical>,<sysphysical>,<syssize>,<loglogical>,<logphysical>,<logsize>,<datalogical1>,<dataphysical1>,<datasize1> [,<datalogical2>,<dataphysical2>,<datasize2>...<datalogical16>,<dataphysical16>,<datasize16>]

15262

10

否

输入的文件大小无效。所有文件都必须至少为 1 MB。

15263

16

否

在帐户查找操作中找不到安全描述符字符串 ‘%s‘ 中的 SID。

15264

16

否

无法创建数据库的 ‘%s‘ 部分。

15265

16

否

在处理安全描述符字符串 ‘%s‘ 时出错。

15266

16

否

无法使数据库 ‘%s‘ 可删除。

15267

16

否

名为 ‘%s‘ 的安全描述符已存在。

15268

10

是

身份验证模式为 %s。

15269

16

否

未创建逻辑数据设备 ‘%s‘。

15271

16

否

@with_log 参数值无效。有效值为 ‘true‘ 或 ‘false‘。

15272

10

否

%s ‘%.*s‘ 不可信,不能执行它。

15273

10

否

解密密钥不正确。

15274

16

否

由于当前安全上下文不可信,因此访问远程服务器的请求遭到拒绝。

15276

16

否

无法设置系统数据库的主密钥密码。

15277

16

否

只有 ‘true‘ 或 ‘false‘ 是 @parameter_value 的有效值。

15278

16

否

登录名 ‘%s‘ 已映射到数据库 ‘%s‘ 中的用户 ‘%s‘。

15279

16

否

必须添加此消息的 us_english 版本后,才能添加 ‘%s‘ 版本。

15280

16

否

只有删除此消息的所有本地化版本后,才能删除其 us_english 版本。

15281

10

否

SQL Server 阻止了对组件 ‘%.*ls‘ 的 %S_MSG ‘%ls‘ 的访问,因为此组件已作为此服务器安全配置的一部分而被关闭。系统管理员可以通过使用 sp_configure 启用 ‘%.*ls‘。有关启用 ‘%.*ls‘ 的详细信息,请参阅 SQL Server 联机丛书中的 "外围应用配置器"。

15282

10

否

已经存在一个名为 ‘%.*ls‘ 或具有用户定义的唯一标识符的密钥,或者您无权创建它。

15283

16

否

名称 ‘%s‘ 包含的字符太多。

15284

16

否

数据库主体已授予或拒绝授予数据库中的对象权限,无法删除。

15285

16

否

特殊词 ‘%s‘ 不能用于逻辑设备名。

15286

16

否

即将终止此过程。无法识别 @action ‘%s‘。请尝试 ‘REPORT‘、‘UPDATE_ONE‘ 或 ‘AUTO_FIX‘。

15287

16

否

即将终止此过程。对于此过程中的登录名参数,‘%s‘ 是禁止使用的值。

15288

10

否

请指定一个解密程序以对密钥进行解密。

15289

16

否

即将终止此过程。当此过程运行时,不能有打开的事务。

15291

16

否

即将终止此过程。缺少 %s 名称 ‘%s‘ 或该名称无效。

15292

10

否

将修复用户 ‘%s‘ 的行,方法是将其登录名链接更新为某个已经存在的登录名。

15293

10

否

如果禁止发生冲突,将修复用户 ‘%s‘ 的行,方法是将其链接更新为新的登录名。

15294

10

否

通过添加新的登录名并更新用户,共修复了 %d 个孤立用户。

15295

10

否

通过更新用户,共修复了 %d 个孤立用户。

15296

16

否

常规加密错误。

15297

16

否

证书、非对称密钥或私钥数据无效。

15299

16

否

公钥的签名无效。

15300

11

否

常规权限类型(%s)的参数值中没有可识别的字母。下列集合中的字母有效: %s。

15301

16

否

只有 Unicode 数据类型才支持排序规则 ‘%s‘,而且不能在数据库或服务器一级设置该排序规则。

15302

11

否

不应使用 Database_Name 来限定此过程中的参数的 owner.object。

15303

11

否

"user options" 配置值(%d)遭拒绝,因为该值将设置不兼容的选项。

15304

16

否

此消息的 ‘%s‘ 版本的严重级别必须与其 us_english 版本的严重级别(%ld)相同。

15305

16

否

@TriggerType 参数值必须是 ‘insert‘、‘update‘ 或 ‘delete‘。

15306

16

否

无法更改被复制或被分发数据库的兼容级别。

15307

16

否

由于该服务器不是为复制设置的,所以无法更改合并发布选项。

15309

16

否

无法更改 model 或 tempdb 数据库的可信状态。

15310

16

是

启动时配置用户实例失败。更新服务器元数据时出错。

15311

16

否

名为 ‘%s‘ 的文件不存在。

15312

16

否

名为 ‘%s‘ 的文件是主文件,无法删除。

15313

10

否

该密钥不是用指定的解密程序加密的。

15314

10

否

或者没有为密钥指定算法,或者为密钥指定的位长度和算法在此 Windows 系统中不存在。

15315

10

否

密钥 ‘%.*ls‘ 未打开。请先打开它,然后再使用它。

15316

10

否

不允许使用全局临时密钥。只能使用局部临时密钥。

15317

10

否

主密钥文件不存在或格式无效。

15318

10

否

设备 ‘%s‘ 上的数据库 ‘%s‘ 的所有片段现在专门用于日志。

15319

17

否

错误: 对数据库 ‘%s‘ (设备 ‘%s‘)执行 DBCC DBREPAIR REMAP 失败。

15320

16

否

对用旧的主密钥加密的 %S_MSG ‘%.*ls‘ 进行解密时出错。可以使用 FORCE 选项忽略此错误并继续此操作,但使用该旧主密钥无法解密的数据将变得不可用。

15321

16

否

从 sys.master_files 删除 ‘%s‘ 时出现了一些问题。

15322

10

否

已从 tempdb 中删除文件 ‘%s‘,这将在服务器重新启动时生效。

15323

16

否

选定的索引对于表 ‘%s‘ 不存在。

15324

16

否

无法为数据库 ‘%s‘ 更改选项 %s。

15325

16

否

当前数据库不包含名为 ‘%ls‘ 的 %s。

15326

10

否

不存在扩展存储过程。

15327

10

否

数据库现在处于离线状态。

15328

10

否

数据库已经离线。

15329

16

否

无法对当前的主密钥进行解密。如果这是数据库主密钥,则在执行此操作之前,应尝试在会话中打开它。可以使用 FORCE 选项忽略此错误并继续此操作,但使用该旧主密钥加密的数据将丢失。

15330

11

否

没有要报告的匹配行。

15331

11

否

由于 SID 重复,用户 ‘%s‘ 无法执行 auto_fix 操作。

15332

10

否

已为此文件设置了私钥。若要更改该私钥,应删除并重新创建证书。

15333

11

否

错误: 合法的 @oldname 引用的是数据库(%s),而不是当前数据库。

15334

10

否

%S_MSG 具有受用户定义密码保护的私钥。若要启用该私钥,需要提供该密码。

15335

11

否

错误: 新名称 ‘%s‘ 已用作 %s 名称,因此会导致重复,这是不允许的。

15336

16

否

对象 ‘%s‘ 无法重命名,因为它参与了强制依赖关系。

15337

10

否

注意: sys.sql_dependencies 显示其他对象(视图、过程等)正在使用旧名称引用此对象。这些对象将成为无效对象,应立即将它们删除并重新创建。

15339

10

否

正在创建 ‘%s‘。

15342

10

否

未给 %S_MSG ‘%.*ls‘ 设置私钥。

15343

10

否

传入的用户名和/或密码无效,或者当前进程权限不足。

15344

16

否

不支持更改 %S_MSG 的所有权。

15345

16

否

类型为 %S_MSG 的实体不能由角色、组或者映射到证书或非对称密钥的主体拥有。

15346

16

否

无法更改由父对象拥有的对象的所有者。请转而更改父对象的所有者。

15347

16

否

无法传输由父对象拥有的对象。

15348

16

否

无法传输绑定到架构的对象。

15349

16

否

无法传输 MS 提供的对象。

15350

16

否

尝试为文件 %.*ls 附加自动命名的数据库,但失败。已存在同名的数据库,或指定的文件无法打开或位于 UNC 共享目录中。

15351

10

否

正被签名的 CLR 过程/函数/类型引用了一个既没有用强名称又没有用程序集签名的程序集。

15352

16

否

无法删除 %S_MSG,因为有一个或多个实体是使用它进行签名或加密的。

15353

16

否

类型为 %S_MSG 的实体不能由角色、组、应用程序角色或者映射到证书或非对称密钥的主体拥有。

15354

10

否

用法: sp_detach_db <数据库名称>, [TRUE|FALSE], [TRUE|FALSE]

15356

16

否

当前应用程序角色已删除。当前安全上下文包含无效的数据库用户上下文。

15357

16

否

当前安全上下文是由 "%ls" 设置的。它不能用语句 "%ls" 还原。

15358

10

否

应将用户定义的文件组设为只读。

15359

16

否

无法将函数单元 ‘%.*ls‘ 添加到组件 ‘%.*ls‘ 中。此单元已向该组件注册。

15360

16

否

尝试加载 xpstar dll 以便从 LSA 读取代理的代理帐户时出错。

15361

16

否

尝试从 LSA 中读取 SQLAgent 代理帐户凭据时出错。

15362

16

否

尝试创建 ‘%.*ls‘ 凭据时出错。

15364

16

是

无法生成 SQL Server 的用户实例。仅集成的连接才可以生成用户实例。该连接将关闭。%.*ls

15365

16

是

无法生成 SQL Server 的用户实例。只有 Builtin\Users 的成员才可以生成用户实例。该连接将关闭。%.*ls

15366

16

是

内存不足,无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15367

16

是

由于在生成唯一用户实例名时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15368

16

是

由于读取注册表项时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15369

16

是

由于模拟客户端时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15370

16

是

由于复制数据库文件时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15371

16

是

由于创建用户实例事件时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15372

16

是

由于启动用户实例的进程时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15373

16

是

由于获取用户实例的进程信息时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15374

16

是

由于在将用户实例信息保持在系统目录中时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15375

16

是

由于在与用户实例建立连接时出错,导致无法生成 SQL Server 的用户实例。该连接将关闭。%.*ls

15376

16

是

无法生成 SQL Server 的用户实例。只有 SQL Server Express 版本能够让您生成用户实例。该连接将关闭。%.*ls

15377

16

是

启动时配置用户实例失败。将用户添加到 sysadmin 角色时出错。

15378

16

是

启动时配置用户实例失败。在 MASTER DB 中配置系统数据库条目时出错。

15380

16

是

启动时配置用户实例失败。在 MASTER DB 中配置系统数据库路径时出错。

15381

16

是

由于更新该用户实例的进程的安全描述符时出错,导致无法生成 SQL Server 的用户实例。

15382

16

是

由于检索用户的本地应用程序数据路径时出错,导致无法生成 SQL Server 的用户实例。请确保该用户在此计算机上有本地用户配置文件。该连接将关闭。%.*ls

15383

16

是

禁止在 SQL Server 中生成用户实例。请使用 sp_configure ‘user instances enabled‘ 生成用户实例。%.*ls

15384

16

是

启动时配置用户实例失败。更新资源管理器 ID 时出错。

15385

16

否

未定义 sid ‘%.*ls‘ 的数据库主体。

15386

16

否

会话中的另一个批处理正在更改安全上下文,不允许开始新的批处理。

15387

11

否

如果合法的对象名指定了数据库,那么该数据库就必须是当前数据库。

15388

11

否

当前数据库中没有与输入名称 ‘%s‘ 匹配的用户表,或者您不具备访问该表的权限。

15389

11

否

XML 索引或空间索引不支持 sp_indexoption。请改用 ALTER INDEX。

15390

11

否

当前数据库中没有与输入名称 ‘%s‘ 匹配的用户表或索引视图。

15391

11

否

XML 索引不支持 sp_indexoption,而该表有 XML 索引。请改用 ALTER INDEX 为全部索引设置该选项。

15392

16

否

此版本的 SQL Server 不支持指定的选项 ‘%s‘,而且该选项不能使用 sp_configure 进行更改。

15393

16

否

对用旧的主密钥加密的链接登录名 ‘%.*ls‘ 的密码进行解密时出错。可以使用 FORCE 选项忽略此错误并继续此操作,但使用该旧主密钥加密的数据将丢失。

15394

16

否

操作系统不支持排序规则 ‘%s‘

15395

11

否

找不到项类型 ‘%s‘ 的旧合法名称。

15396

16

否

名为 ‘%s‘ 的非对称密钥已存在,或已将此非对称密钥添加到该数据库中。

15397

16

否

%S_MSG 未使用密码进行保护。解密密码不能用于此操作。

15398

11

否

只有 dbo 拥有的 master 数据库中的对象才能更改启动设置。

15399

11

否

未能更改启动选项,因为此选项只限于没有参数的对象。

15401

11

否

找不到 Windows NT 用户或组 ‘%s‘。请再次检查该名称。

15402

11

否

‘%s‘ 不是固定服务器角色。

15403

16

否

服务器主体 "%.*ls" 不存在,没有对服务器的访问权限,或您没有所需的权限。

15404

16

否

无法获取有关 Windows NT 组/用户 ‘%ls‘ 的信息,错误代码 %#lx。

15405

11

否

无法使用特殊主体 ‘%s‘。

15406

16

否

无法作为服务器主体执行,因为主体 "%.*ls" 不存在、无法模拟这种类型的主体,或您没有所需的权限。

15407

11

否

‘%s‘ 不是有效的 Windows NT 名称。请给出完整名称: <域\用户名>。

15408

16

否

无法在此批处理中调用 %ls,因为某个同时执行的批已调用了它。

15409

11

否

‘%s‘ 不是角色。

15410

11

否

此数据库中不存在用户或角色 ‘%s‘。

15411

11

否

此数据库中不存在数据库主体或架构 ‘%s‘。

15412

11

否

‘%s‘ 不是已知的固定角色。

15413

11

否

不能使角色成为其自身的成员。

15414

16

否

数据库中包含有索引的视图或计算列,所以无法设置兼容级别。这些索引要求与 SQL Server 兼容的数据库。

15416

16

否

用法: sp_dbcmptlevel [dbname [, compatibilitylevel]]

15418

16

否

只有 sysadmin 角色的成员或数据库所有者才能设置数据库兼容级别。

15419

16

否

所提供的参数 sid 应为 binary(16)。

15420

16

否

此数据库中不存在组 ‘%s‘。

15421

16

否

数据库主体拥有数据库角色,无法删除。

15422

16

否

只能在临时级别上激活应用程序角色。

15425

16

否

未定义 sid ‘%.*ls‘ 的服务器主体。

15426

16

否

必须指定具有这一组属性的提供程序名称。

15427

16

否

必须指定未知产品 ‘%ls‘ 的提供程序名称。

15428

16

否

无法为产品 ‘%ls‘ 指定提供程序或任何属性。

15429

16

否

‘%ls‘ 是无效的产品名称。

15431

16

否

必须指定 @rolename 参数。

15432

16

否

只能在临时级别上执行存储过程 ‘%s‘。

15433

16

否

所提供的参数 sid 正在使用。

15434

16

否

无法删除登录名 ‘%s‘,因为该用户当前正处于登录状态。

15435

10

否

已成功地发布了数据库。

15436

10

否

操作成功,用户现在可以订阅该数据库了。

15437

10

否

已成功地用合并复制发布了数据库。

15438

10

否

数据库已经联机。

15439

10

否

数据库现在处于联机状态。

15440

10

否

不再发布数据库。

15441

10

否

数据库已无法再订阅。

15442

10

否

数据库已无法再进行合并发布。

15443

10

否

正在对更改过的数据库执行检查点操作。

15448

16

否

无法将计算机密钥执行的加密添加到服务主密钥,因为服务主密钥无法解密或不存在。

15450

10

否

新语言已插入。

15451

16

否

从服务主密钥删除加密失败。不存在由计算机密钥执行的加密。

15452

10

否

无备用语言。

15453

10

否

us_english 始终可用,即便它不在 syslanguages 中。

15454

10

否

语言已删除。

15455

16

否

向服务主密钥添加加密失败。已经存在由计算机密钥执行的加密。

15457

10

否

配置选项 ‘%ls‘ 已从 %ld 更改为 %ld。请运行 RECONFIGURE 语句进行安装。

15458

10

否

数据库已删除。

15459

10

否

在当前数据库中,指定的对象引用了以下内容:

15460

10

否

在当前数据库中,以下内容引用了指定的对象:

15461

10

否

该对象未引用任何其他对象,其他对象也未引用该对象。

15462

10

否

文件 ‘%s‘ 已关闭。

15463

10

否

设备已除去。

15464

16

否

不支持的私钥格式或密钥长度。

15465

16

否

私钥密码无效。

15466

16

否

解密过程中出错。

15468

16

否

生成 %S_MSG 的过程中出错。

15469

10

否

未给对象 ‘%ls‘ 定义任何约束,或者您没有所需的权限。

15470

10

否

没有外键引用表 ‘%ls‘,或者您没有引用表的相关权限。

15471

10

否

对象 ‘%ls‘ 的文本已加密。

15472

10

否

对象 ‘%ls‘ 没有任何索引,或者您没有所需的权限。

15474

16

否

私钥无效。私钥与 %S_MSG 的公钥不匹配。

15475

10

否

数据库已重命名并处于单用户模式。

15477

10

否

注意: 更改对象名的任一部分都可能会破坏脚本和存储过程。

15482

16

否

无法更改具有索引视图的表的所有者。

15490

10

否

依赖别名也已删除。

15497

10

否

无法使用 sp_addlogin 添加登录名(用户 = %s)。即将终止此过程。

15499

10

否

依赖别名已映射到新的数据库所有者。

15500

10

否

依赖别名已删除。

15502

10

否

正将数据库所有者设置为 SA。

15503

10

否

正将所有对象的所有权交给数据库所有者。

15504

10

否

正从系统目录中删除 guest 和数据库所有者之外的用户。

15505

16

否

无法更改对象 ‘%ls‘ 或其某个子对象的所有者,因为新所有者 ‘%ls‘ 已有一个同名的对象。

15506

16

否

签名时出错。

15507

16

否

此操作所需的密钥似乎已损坏。

15508

16

否

生成此操作所需的密钥时出错。

15509

16

否

无法删除该密码,因为另一个数据库可能正在使用它。

15510

16

否

无法启用密码为空的登录名。

15511

10

否

已将默认值绑定到列。

15512

10

否

已将默认值绑定到数据类型。

15513

10

否

已将新默认值绑定到指定用户数据类型的列。

15514

10

否

已将规则绑定到表的列。

15515

10

否

已将规则绑定到数据类型。

15516

10

否

已将新规则绑定到指定用户数据类型的列。

15517

16

否

无法作为数据库主体执行,因为主体 "%.*ls" 不存在、无法模拟这种类型的主体,或您没有所需的权限。

15518

16

否

无法作为 Windows 令牌执行。该令牌无效或您没有所需的权限。

15519

10

否

已解除了表列与其默认值之间的绑定。

15520

10

否

已解除了数据类型与其默认值之间的绑定。

15521

10

否

已解除了指定用户数据类型的列与其默认值之间的绑定。

15522

10

否

已解除了表列与规则之间的绑定。

15523

10

否

已解除了数据类型与规则之间的绑定。

15524

10

否

已解除了指定用户数据类型的列与其规则之间的绑定。

15525

10

否

sp_checknames 用于搜索非 7 位的 ASCII 字符。

15526

10

否

在系统表的多个重要的列中。已搜索

15527

10

否

以下列:

15528

10

否

在 master 中:

15529

16

否

无法作为票证执行。该令牌无效或您没有所需的权限。

15530

16

否

名为 "%.*ls" 的 %S_MSG 已存在。

15531

16

否

安全描述符信息无效。

15532

16

否

安全描述符无效,因为它未包含有关其所有者或其主组的信息。

15533

16

否

‘%ls‘ 语句中提供的数据类型无效。

15534

16

否

在 ‘%ls‘ 语句中生成 Cookie 失败。

15535

16

否

无法设置主体 ‘%.*ls‘ 的凭据。

15536

10

否

在所有数据库中:

15537

16

否

登录名 ‘%.*ls‘ 没有访问服务器的权限。

15538

16

否

登录名 ‘%.*ls‘ 没有访问数据库的权限。

15539

16

否

无法删除用户 ‘%s‘,只能禁用它。在当前数据库中已禁用该用户。

15540

16

否

标识字符串太长。标识字符串的字符个数应不超过 %d。

15541

16

否

凭据 ‘%.*ls‘ 被某服务器主体使用,因此无法删除它。

15542

10

否

如果不指定加密程序,则无法创建密钥。

15556

10

否

无法使用指定的 %S_MSG 进行解密或加密,因为它没有私钥或者为私钥提供的密码不正确。

15557

10

否

已存在一个由 %S_MSG ‘%.*ls‘ 创建的 %S_MSG。

15558

10

否

无法删除 %S_MSG ‘%.*s‘ 所创建的 %S_MSG。

15559

10

否

无法删除 %S_MSG ‘%.*ls‘,因为有一个 %S_MSG 映射到它。

15560

10

否

无法添加或删除 ‘%.*ls‘ 上的签名,因为只能对模块签名。

15561

10

否

产品的此版本仅支持基于证书或非对称密钥的签名。

15562

10

否

正在执行的模块不可信。需要对该模块的数据库的所有者授予身份验证时所需的权限,或者需要对该模块进行数字签名。

15563

10

否

没有为 %S_MSG 设置私钥。

15574

10

否

此对象没有任何统计信息。

15575

10

否

此对象没有任何统计信息或索引。

15576

16

否

不能在服务器 ‘%ls‘ 上设置网络名称,因为该服务器不是链接 SQL Server。

15577

10

否

警告: 不支持引用发起服务器的链接服务器。如果希望用分为四个部分的名称来引用本地表,请使用实际的服务器名称而不要用别名。

15578

16

否

数据库中已存在主密钥。执行此语句前,请先删除该主密钥。

15579

16

否

向对称密钥添加加密失败。可能已存在由 %S_MSG ‘%.*s‘ 执行的加密。

15580

16

否

无法删除 %S_MSG,因为 %S_MSG ‘%.*s‘ 是由它加密的。

15581

16

否

在执行此操作之前,请在数据库中创建一个主密钥或在会话中打开该主密钥。

15583

10

否

正被签名的模块已标记为作为所有者执行。如果所有者更改,该签名将无效。

15584

10

否

对用旧的主密钥加密的 %S_MSG ‘%.*ls‘ 进行解密时出错。由于指定了 FORCE 选项,因此忽略了该错误。

15585

10

否

无法对当前的主密钥进行解密。由于指定了 FORCE 选项,因此忽略了该错误。

15586

16

否

在 master 数据库与资源数据库之间同步系统证书时出错。

15587

16

否

无法更改程序集 ‘%.*ls‘ 的所有者,因为依赖程序集 ‘%.*ls‘ 不为该新所有者拥有。

15588

10

否

新旧主密钥完全相同。不需要重新加密数据。

15589

16

否

由于 cookie 无效,因此无法还原当前安全上下文。

15590

16

否

只能在特殊级别对 ‘Execute As‘ 语句使用 ‘No Revert‘ 或 ‘Cookie‘ 选项。

15591

16

否

使用此语句无法还原当前安全上下文。‘Revert‘ 语句可能需要,也可能不需要 cookie,具体取决于该上下文是如何使用 ‘Execute As‘ 语句设置的。

15592

16

否

无法取消设置应用程序角色,因为未设置任何角色或 cookie 无效。

15593

16

否

对用旧的主密钥加密的链接登录名 ‘%.*ls‘ 的密码进行解密时出错。由于指定了 FORCE 选项,因此忽略了该错误。

15594

16

否

已为数据库 ‘%.*ls‘ 设置了该密码

15595

16

否

无法删除该密码,因为未给数据库 ‘%.*ls‘ 设置该密码

15596

10

否

警告: 对具有行级别安全性的表使用 UNIQUE 索引、PRIMARY KEY 约束或 UNIQUE 约束可能导致信息泄漏。

15597

10

否

警告: 对具有行级别安全性的表使用 IDENTITY 列可能导致信息泄漏。

15598

10

否

警告: 对具有行级别安全性的表使用索引视图可能导致信息泄漏。

15599

10

否

警告: 如果对启用了行级别安全的表使用 FOREIGN KEY 约束,就可能导致执行不允许在行级别执行的信息泄漏、修改或删除等操作。

15600

15

否

为过程 ‘%s‘ 指定的参数或选项无效。

15601

16

否

没有为当前数据库启用全文搜索。请使用 sp_fulltext_database 来启用全文搜索。不再推荐使用禁用和启用数据库的全文搜索功能。请更改您的应用程序。

15612

16

否

DBCC DBCONTROL 错误。未将数据库设为只读。

15615

16

否

DBCC DBCONTROL 错误。未将数据库设为单用户模式。

15622

10

否

无权访问数据库 ‘%s‘。

15625

10

否

无法识别 ‘%ls‘ 参数的选项 ‘%ls‘。

15626

10

否

您试图在没有活动事务的情况下获取事务应用程序锁。

15627

10

否

sp_dboption 命令失败。

15635

16

否

无法执行 ‘%ls‘,因为数据库处于只读访问模式下。

15645

16

否

列 ‘%ls‘ 不存在。

15646

16

否

列 ‘%ls‘ 不是计算列。

15647

10

否

所有具有架构绑定的视图均未引用表 ‘%ls‘。

15650

10

否

正在更新 %s

15651

10

否

已更新 %d 条索引/统计信息,%d 不需要更新。

15652

10

否

%s 已更新...

15653

10

否

%s,不需要更新...

15654

10

否

表 %s: 无法对该表执行该操作,因为它的聚集索引已禁用。

15656

16

否

无法从 XML 数据类型创建用户定义类型。

15657

16

否

Vardecimal 存储格式在系统数据库 ‘%s‘ 中不可用。

15658

16

否

无法对数据库快照运行 sp_resetstatus。

15659

16

否

为参数 schema_name 指定的架构 ‘%ls‘ 不存在。

15660

16

否

存储过程 sp_estimate_data_compression_savings 不支持压缩 XML 索引。

15661

16

否

存储过程 sp_estimate_data_compression_savings 不支持压缩临时表。

15662

16

否

存储过程 sp_estimate_data_compression_savings 不支持对具有稀疏列或列集的表进行压缩。

 

注:在此特别感谢msdn,    本文根据msdn翻译.

评论(0)
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!