(带权并查集)poj 1988

时间:2015-04-05 11:45:00   收藏:0   阅读:104
Cube Stacking
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 20392   Accepted: 7148
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M‘ for a move operation or a ‘C‘ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
#define maxn 30010
int n;
int dist[maxn],fa[maxn],rnk[maxn];
char opt[2];
int find(int x)
{
    if(fa[x]==x)
        return fa[x];
    int temp=fa[x];
    fa[x]=find(fa[x]);
    dist[x]+=dist[temp];
    return fa[x];
}
int main()
{
    int x,y;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<maxn;i++)
        {
            fa[i]=i;
            dist[i]=0;
            rnk[i]=1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%s",opt);
            if(opt[0]==‘M‘)
            {
                scanf("%d%d",&x,&y);
                int fx,fy;
                fx=find(x),fy=find(y);
                if(fx!=fy)
                {
                    fa[fy]=fx;
                    dist[fy]=rnk[fx];
                    rnk[fx]+=rnk[fy];
                }
            }
            else if(opt[0]==‘C‘)
            {
                scanf("%d",&x);
                printf("%d\n",rnk[find(x)]-dist[x]-1);
            }
        }
    }
    return 0;
}

  

评论(0
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!