杭电 HDU ACM 1393 Weird Clock

时间:2015-04-05 09:10:44   收藏:0   阅读:104

Weird Clock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2752    Accepted Submission(s): 990


Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won‘t move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin‘s type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.
 

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.
 

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output "Impossible".
 

Sample Input
30 1 0 0
 

Sample Output
1
 

Author
DU, Peng
 
下面代码跳出while循环有两种情况 :s=0和在0——59内找到循环点。分别用flag标志两种情况。
好玩的是 如何记录是否某个s已经出现过。
#include<iostream>
using namespace std;
int main()
{
	int s,d;
	while(cin>>s>>d,s+d)
	
	{
		int count=0;int ls[10000];int flag=0;
		memset(ls,0,sizeof(ls));
		while(s)
		{
			ls[s]=1;
			count++;
			s+=s*d;s%=60;
			if(ls[s])
			{
				cout<<"Impossible\n";
				flag=1;
				break;
			}

			
		}
		if(!flag)
		cout<<count<<endl;
	}
	return 0;
}


 
 
评论(0
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!