hdu 1342 记忆化深搜

时间:2015-03-27 22:25:37   收藏:0   阅读:104

Lotto

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1657    Accepted Submission(s): 811


Problem Description
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn‘t increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.
 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.
 

Sample Input
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

Sample Output
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34
 

Source

题意:一个对牌游戏的新玩法:从49个数中抽出来k个数字,进行排列,并且规定是升序,满足字典序,求解所有的可能数!
 考查知识点:记忆化深搜
大坑:全局变量不要乱用!
//考查知识点:深搜
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int i,n;
int a[55],s[55],visit[55];
void dfs(int k)
{
	int i;//此处使用全局变量的i会 出错,原因我也不是太清楚 
	if(k==6)//样例中的是输出6个数字
	{
		printf("%d",s[0]);
		for(i=1;i<6;++i)
		{
			printf(" %d",s[i]);
		}
		puts("");
	}
	else
	{
		for(i=0;i<n;++i)
		{
			if(!visit[a[i]]&&(k==0||a[i]>s[k-1]))//满足升序条件
			{
				s[k]=a[i];
				visit[a[i]]=1;
				dfs(k+1);
				visit[a[i]]=0;
			}
		}
	}
}
int main()
{
	int count=1;
	while(~scanf("%d",&n),n)
	{
		if(!count)//控制格式输出
		puts("");
		else
		count=0;
		for(i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
		}
		sort(a,a+n);
		memset(visit,0,sizeof(visit));//初始化
		dfs(0);//从零开始 遍历6次
	}
	return 0;
} 


评论(0
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!