POJ Ubiquitous Religions

时间:2015-03-22 09:12:28   收藏:0   阅读:104
Language:
Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 26140   Accepted: 12872

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended
赤裸裸的并查集
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int father[50005],vis[50005];
int find(int x){
	return x==father[x]?x:father[x]=find(father[x]);
}
int main()
{
	int m,n,i,j,ans,t=1;
	while(scanf("%d%d",&n,&m)&&m&&n){
		for(i=1;i<=n;++i)
			father[i]=i;
		for(i=0;i<m;++i){
			int a,b;
			scanf("%d%d",&a,&b);
			a=find(a);b=find(b);
			if(a!=b)father[a]=b;
		}
		memset(vis,0,sizeof(vis));
		ans=0;
		for(i=1;i<=n;++i){
			if(!vis[find(i)]){
				ans++;
				vis[find(i)]=1;
			}
		}
		printf("Case %d: %d\n",t++,ans);
	}
	return 0;
}
Accepted 524K 297MS C++ 724B
         
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAX=50000+5;
int father[MAX],vis[MAX];
int find(int x){
	int r=x;
	while(r!=father[r]){
		r=father[r];
	}
	int j=x,i;
	while(j!=r){
		i=father[j];
		father[j]=r;
		j=i;
	}
	return r;
}
void join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy)father[fx]=fy;
}
int main()
{
	int t=1,m,n,a,b,i;
	while(scanf("%d%d",&n,&m)&&n&&m){
		for(i=1;i<=n;++i){
			father[i]=i;
			vis[i]=0;
		}
		for(i=0;i<m;++i){
			scanf("%d%d",&a,&b);
			join(a,b);
		}
		int ans=0;
		for(i=1;i<=n;++i){
			if(!vis[find(i)]){
				ans++;
				vis[find(i)]=1;
			}
		}
		printf("Case %d: %d\n",t++,ans);
	}
	return 0;
}
Accepted 420K 329MS C++ 866B




评论(0
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!