PAT Advanced 1013 Battle Over Cities (25分)

时间:2020-02-01 01:04:58   收藏:0   阅读:91

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city?1??-city?2?? and city?1??-city?3??. Then if city?1?? is occupied by the enemy, we must have 1 highway repaired, that is the highway city?2??-city?3??.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3
 

Sample Output:

1
0
0

PAT 图的遍历,这道题考察了图的遍历。我们要检查城市未连通的量,仅需要进行一次深度遍历,

进行计数,然后减去初始的1次,剩余的就是需要进行连通的了

#include <iostream>
#include <algorithm>
#define VERNUM 1010
using namespace std;
bool edge[VERNUM][VERNUM];
bool vis[VERNUM];
int N, M, K;
void dfs(int v) {
    vis[v] = true;
    for(int i = 1; i <= N; i++){
        if(vis[i] == false && edge[v][i] == 1)
            dfs(i);
    }
}
int main() {
    /** N 城市个数 M 剩余的高速公路数量 K 检查过的城市数量 **/
    /** 该题要求,去除一个顶点,判定是否是连通图 */
    scanf("%d%d%d", &N, &M, &K);
    int a, b, tmp_city;
    for(int i = 0; i < M; i++) {
        scanf("%d%d", &a, &b);
        edge[a][b] = edge[b][a] = 1;
    }
    for(int i = 0; i < K; i++) {
        fill(vis, vis + VERNUM, false);
        scanf("%d", &tmp_city);
        int cnt = 0;
        vis[tmp_city] = true;
        for(int j = 1; j <= N; j++) {
            if(vis[j] == false) {
                dfs(j);
                cnt++;
            }
        }
        printf("%d\n", cnt - 1);
    }
    return 0;
}

 

评论(0
© 2014 mamicode.com 版权所有 京ICP备13008772号-2  联系我们:gaon5@hotmail.com
迷上了代码!